読者です 読者をやめる 読者になる 読者になる

nakano-tomofumiのブログ

データマエショリストのメモ

airflow と格闘中 (11)

まだまだ

pysqlite2 がない

apt-get install sqlite3-dev
pip install pysqlite

click がない?

次のエラー

[2017-05-15 10:12:53,877] {__init__.py:57} INFO - Using executor SequentialExecutor
Traceback (most recent call last):
  ....
  File "/xxxxxxxxx/python/venv/lib/python2.7/site-packages/flask/cli.py", line 17, in <module>
    import click
pip install flask

を実行しても、インストール済みと表示される。

次を参考に、

python flask import error - Stack Overflow

sudo apt-get install python-flask

を実行。virtualenv を使っているからか、解決せず。 pip install flask のメッセージをもう一度確認してみる。

Requirement already satisfied (use --upgrade to upgrade): flask in /xxxxxxxxx/python/venv/lib/python2.7/site-packages

そういうこと?

pip install --upgrade flask

で無事インストール。私の python 環境構築力が問われる。